Aquí algunas respuestas a problemas con Ubuntu 16.04 LTS

Loading...

Si eres de los que has notado que estas pasando trabajo para instalar programas, aplicaciones o actualizaciones nuevas a Ubuntu, a partir de la actualización o la instalación de cero de Xenial Xerus, no es culpa de Canonical aunque no lo creas.

La culpa directamente la tiene los dueños de repositorios de aplicaciones instalables en sistemas basados en Debian como Ubuntu y sí, a pesar que el LTS de Ubuntu Xenial Xerus era uno de los más esperados, unos inesperados errores han estado plagando a los instaladores de Ubuntu y por ejemplo:

/usr/share/appgrid/appdata/helpers.py:9: PyGIWarning: Soup was imported without specifying a version first. Use gi.require_version('Soup', '2.4') before import to ensure that the right version gets loaded.

from gi.repository import GLib, GObject, Soup

El anterior es un error que está saliendo desde que uno quiere hacer las actualizaciones forzadas a través de BASH y verificando en Launchpad, el error simplemente significa que el componente de PyObject ahora detecta si un código gi si necesita especificar una version y en particular afecta al proceso llamado Soup el cual venia ya por defecto en Ubuntu y aunque no es algo fatal, si molesta, pero nada que ver con el funcionamiento del OS.

Por otra parte, como observan el error que es una advertencia por ende el “W”:

W: http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAXXXCEE4AB83976DCA040830F7FACXXX uses weak digest algorithm (SHA1)

W: There is no public key available for the following key IDs:

1397BC53640DXXXX

Y es pasado error es el que está generalmente provocando las situaciones pero esto no es culpa de Canonical como ya se dijo anteriormente, de hecho, esto demuestra la responsabilidad de la productora de la distro de Linux, el hecho que ya pasaron la página con el método de encriptacion SHA1, la cual la están considerando obsoleta y ahora Ubuntu advierte sobre esto.

Hay dos problemas con esto, al parecer, muchos dueños de repositorios (increíblemente, Google incluido) no han adoptado los nuevos cifrados y encriptación para SHA2 el cuál es el aceptado actualmente y por ende, esto también está afectando a archivos instaladores .deb, el cual no se pueden instalar.

Loading...

Screenshot XenialXerusGeeZus

Ahora, una solución para forzar la instalación cuando tienes una imagen .deb, tienes que hacer lo siguiente (todo trabajado desde el Terminal):

-Tienes que ir al folder donde tienes grabado el instalador de la aplicación

cd /Downloads

-Pides a Ubuntu que empiece el proceso de instalación

sudo dpkg -i el_nombre_del_programa.deb

-Si te sale una confirmación de instalación pero con errores, significa que Ubuntu no pudo bajar ninguno o casi todos los requisitos del programa o la aplicación y puedes forzarlo a buscarlos con el comando:

sudo apt-get -f install

Advertimos de tratar de correr el programa sin haber hecho la última función ya que puedes provocar fallas y dificultar aun más la cosa.

Canonical desde hace semanas ha dicho que ha notificado a los dueños de repositorios de hacer los cambios pertinentes, pero lamentablemente quedará de ellos el hacer los arreglos pertinentes y actualizar sus llaves publicas.

Jesús J. Nieves-Padilla
Amante de la Tecnología, Blogging, Música y del Vacilón. Fanático de Linux, Ingeniero, Critico Tecnológico, Humano. "Tantas cosas por las que la gente trolea y a sabiendas que la vida es una, prefiero dejarlos como locos."